Today is:   Dec 12, 2017

Brief Banners

Institute Mihailo Pupin
Institute Mihailo Pupin is the leading Serbian R&D institution in the field of Information & Communication Techologies.

Automation & Control Systems Ltd
The Automation & Control Systems Ltd is the core division of the Institute Mihailo Pupin, and the owner of the VIEW4 application.

References
The long list of the Institute's references and customers is the best proof of its high professional and techological achievments.

ATLAS Systems
The other related IMP project: ATLAS Systems (ATLAS-MAX & pikoATLAS) provides the underlying RTU and PLC infrastructure needed for VIEW4 control implementation

You are here:     VIEW for You Specification System Software
System Software Requirements

 

The required VIEW4 System Software platform is the Linux platform.  A number of Linux 32/64 bits versions and kernel releases are acceptable, as well as supporting system utilities.  The list of needed system software components follows (pay attention, this is not a mandatory list):

  • A complete Linux distribution – different flavors are acceptable: Centos, Fedora, SuSE, RedHat …, and proven releases are recommended.  It is assumed a proper hardware compliant installation, which includes all standard libraries and system utilities.  The bash shell (Bourne Again Shell) is the standard one; the C++ compiler, X11R6, Qmail (or Sendmail/Postfix) and NTP are also mandatory.
  • Installation of MySQL Server (release 4 or higher) and related utilities, libraries and drivers: MySQL++, ODBC support (myodbc, tclodbc, libiodbc) .
  • Installation of Tcl/Tk (release 8.3.5 or higher), including a number of Tcl utilities and TkTables.
  • Installation of Qt toolkit for Linux/X11 (v3 or higher)
  • Installation of Perl (release 5), including a number of related Perl modules.
  • Installation of PHP (release 4.3.9 or higher) - PHP configuration should support Apache2 Web server.
  • Installation of Apache 2 HTTP Server (version 2) - built for SSL support and PHP implementation.
  • Installation of JAVA (JSF 2 and JDK 5 or higher) – new developments are primarily based on Java.
  • Installation of Tomcat (version 5.5 and higher) – optionally, required for specific applications.